SPAZ - Brakujące wtyczki dla PulseAudio

Objawy

Przypadek oparty na grze SPAZ :) Informacja p brakujących wtyczkach pojawia się w konsoli zaraz po uruchomieniu gry.

camelek@debian:~$ /usr/local/games/spaz/SPAZ
ALSA lib conf.c:3314:(snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so
ALSA lib control.c:951:(snd_ctl_open_noupdate) Invalid CTL hw:0
AL lib: alsa.c:989: control open (0): No such file or directory
ALSA lib conf.c:3314:(snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so
ALSA lib control.c:951:(snd_ctl_open_noupdate) Invalid CTL hw:0
AL lib: alsa.c:1057: control open (0): No such file or directory

Problem

Jeśli system operacyjny jest 64-bitowy jedynym brakiem są wtyczki w wersji 32-bitowej, które należy zainstalować. Obecnie dystrybucje wprowadzają Multiarch, dzięki czemu przesiadanie się z jednej architektury na drugą staje się mniej uciążliwe. Nie jest to jednak jedyny powód powstania tej technologii, więcej informacji w linkach zewnętrznych na dole strony.

Rozwiązanie

# aptitude install libasound2-plugins:i386

Dodatkowe biblioteki

# aptitude install libopenal1:i386 libportaudio2:i386

Linki zewnętrzne

O ile nie zaznaczono inaczej, treść tej strony objęta jest licencją GNU Free Documentation License.